CVE-2008-5101

NameCVE-2008-5101
DescriptionBuffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs505399

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optipng (PTS)jessie (security), jessie0.7.5-1+deb8u2fixed
stretch (security), stretch0.7.6-1+deb9u1fixed
buster, sid0.7.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
optipngsource(unstable)0.6.1.1-1high505399
optipngsourceetch(not affected)

Notes

[etch] - optipng <not-affected> (Vulnerable code not present referring to upstream)

Search for package or bug name: Reporting problems