CVE-2008-5249

NameCVE-2008-5249
DescriptionCross-site scripting (XSS) vulnerability in MediaWiki 1.13.0 through 1.13.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1901-1, DTSA-186-1
NVD severitymedium (attack range: remote)
Debian Bugs508868

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)wheezy, wheezy (security)1:1.19.20+dfsg-0+deb7u3fixed
stretch (security), stretch1:1.27.4-1~deb9u1fixed
buster, sid1:1.27.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.13.3-1medium508868
mediawikisourceetch(not affected)
mediawikisourcelenny1:1.12.0-2lenny2mediumDTSA-186-1
mediawiki1.7source(unstable)(unfixed)medium
mediawiki1.7sourceetch1.7.1-9etch1mediumDSA-1901-1

Notes

[etch] - mediawiki <not-affected> (metapackage)

Search for package or bug name: Reporting problems