CVE-2008-5252

NameCVE-2008-5252
DescriptionCross-site request forgery (CSRF) vulnerability in the Special:Import feature in MediaWiki 1.3.0 through 1.6.10, 1.12.x before 1.12.2, and 1.13.x before 1.13.3 allows remote attackers to perform unspecified actions as authenticated users via unknown vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1901-1, DTSA-186-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs508870
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)squeeze (security), squeeze1:1.15.5-2squeeze6fixed
wheezy, wheezy (security)1:1.19.20+dfsg-0+deb7u3fixed
jessie, sid1:1.19.20+dfsg-2.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.13.3-1medium508870
mediawikisourceetch(not affected)
mediawikisourcelenny1:1.12.0-2lenny2mediumDTSA-186-1
mediawiki1.7source(unstable)(unfixed)medium
mediawiki1.7sourceetch1.7.1-9etch1mediumDSA-1901-1

Notes

[etch] - mediawiki <not-affected> (metapackage)

Search for package or bug name: Reporting problems