CVE-2008-5262

NameCVE-2008-5262
DescriptionMultiple stack-based buffer overflows in the iGetHdrHeader function in src-IL/src/il_hdr.c in DevIL 1.7.4 allow context-dependent attackers to execute arbitrary code via a crafted Radiance RGBE file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1717-1, DTSA-184-1
NVD severityhigh (attack range: remote)
Debian Bugs511844, 512122
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
devil (PTS)squeeze1.7.8-6fixed
wheezy1.7.8-6.1fixed
jessie, sid1.7.8-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
devilsource(unstable)1.7.5-4low511844, 512122
devilsourceetch1.6.7-5+etch1highDSA-1717-1
devilsourcelenny1.6.8-rc2-3+lenny1highDTSA-184-1

Notes

fix for 1.7.5-3 incomplete, see #512122

Search for package or bug name: Reporting problems