CVE-2008-5314

NameCVE-2008-5314
DescriptionStack consumption vulnerability in libclamav/special.c in ClamAV before 0.94.2 allows remote attackers to cause a denial of service (daemon crash) via a crafted JPEG file, related to the cli_check_jpeg_exploit, jpeg_check_photoshop, and jpeg_check_photoshop_8bim functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1680-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs507624
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)squeeze0.98.1+dfsg-1+deb6u3fixed
squeeze (lts)0.98.7+dfsg-0+deb6u2fixed
wheezy0.98.5+dfsg-0+deb7u2fixed
jessie0.98.7+dfsg-0+deb8u1fixed
stretch, sid0.98.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.94.dfsg.2-1medium507624
clamavsourceetch0.90.1dfsg-4etch16mediumDSA-1680-1

Search for package or bug name: Reporting problems