CVE-2008-5587

NameCVE-2008-5587
DescriptionDirectory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1693-1
NVD severitymedium (attack range: remote)
Debian Bugs508026

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phppgadmin (PTS)wheezy5.0.4-1fixed
jessie5.1-1.1fixed
buster, sid, stretch5.1+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phppgadminsource(unstable)4.2.1-1.1low508026
phppgadminsourceetch4.0.1-3.1etch1mediumDSA-1693-1

Notes

register_globals=on is required
http://www.milw0rm.com/exploits/7363

Search for package or bug name: Reporting problems