CVE-2008-5624

NameCVE-2008-5624
DescriptionPHP 5 before 5.2.7 does not properly initialize the page_uid and page_gid global variables for use by the SAPI php_getuid function, which allows context-dependent attackers to bypass safe_mode restrictions via variable settings that are intended to be restricted to root, as demonstrated by a setting of /etc for the error_log variable.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1789-1, DTSA-188-1
NVD severityhigh (attack range: remote)
Debian Bugs508021, 559787
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.44-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.12+dfsg-0+deb8u1fixed
stretch5.6.11+dfsg-1fixed
sid5.6.12+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)(unfixed)medium559787
php5source(unstable)5.2.6.dfsg.1-1medium508021
php5sourceetch5.2.0+dfsg-8+etch15highDSA-1789-1
php5sourcelenny5.2.6.dfsg.1-1+lenny3highDSA-1789-1

Search for package or bug name: Reporting problems