CVE-2008-5687

NameCVE-2008-5687
DescriptionMediaWiki 1.11, and other versions before 1.13.3, does not properly protect against the download of backups of deleted images, which might allow remote attackers to obtain sensitive information via requests for files in images/deleted/.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-186-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3fixed
stretch (security)1:1.27.7-1~deb9u5fixed
buster1:1.31.7-1~deb10u1fixed
buster (security)1:1.31.10-1~deb10u1fixed
bullseye, sid1:1.35.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourceetch(not affected)
mediawikisourcelenny1:1.12.0-2lenny2DTSA-186-1
mediawikisource(unstable)1:1.13.3-1low
mediawiki1.7sourceetch(not affected)
mediawiki1.7source(unstable)(unfixed)

Notes

[etch] - mediawiki1.7 <not-affected> (The backup feature was introduced in 1.11)
[etch] - mediawiki <not-affected> (metapackage)

Search for package or bug name: Reporting problems