CVE-2008-5718

NameCVE-2008-5718
DescriptionThe papd daemon in Netatalk before 2.0.4-beta2, when using certain variables in a pipe command for the print file, allows remote attackers to execute arbitrary commands via shell metacharacters in a print request, as demonstrated using a crafted Title.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1705-1, DTSA-183-1
NVD severityhigh
Debian Bugs510585

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netatalk (PTS)stretch (security), stretch2.2.5-2+deb9u1fixed
buster3.1.12~ds-3fixed
bookworm, bullseye3.1.12~ds-8fixed
sid3.1.12~ds-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netatalksourceetch2.0.3-4+etch1DSA-1705-1
netatalksourcelenny2.0.3-11+lenny1DTSA-183-1
netatalksource(unstable)2.0.4~beta2-1medium510585

Search for package or bug name: Reporting problems