CVE-2008-6393

NameCVE-2008-6393
DescriptionPSI Jabber client before 0.12.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a file transfer request with a negative value in a SOCKS5 option, which bypasses a signed integer check and triggers an integer overflow and a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1741-1
NVD severityhigh (attack range: remote)
Debian Bugs518468
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
psi (PTS)squeeze0.14-2fixed
wheezy0.14-3fixed
stretch, sid, jessie0.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
psisource(unstable)0.12.1-1low518468
psisourceetch(not affected)
psisourcelenny0.11-9highDSA-1741-1

Notes

[etch] - psi <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems