CVE-2008-6792

NameCVE-2008-6792
Descriptionsystem-tools-backends before 2.6.0-1ubuntu1.1 in Ubuntu 8.10, as used by "Users and Groups" in GNOME System Tools, hashes account passwords with 3DES and consequently limits effective password lengths to eight characters, which makes it easier for context-dependent attackers to successfully conduct brute-force password attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs527952

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
system-tools-backends (PTS)bookworm, bullseye, sid, trixie2.10.2-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
system-tools-backendssourceetch(not affected)
system-tools-backendssourcelenny2.6.0-2lenny3
system-tools-backendssource(unstable)2.6.0-6.1low527952

Notes

[etch] - system-tools-backends <not-affected> (SHA was added to crypt(3) post-etch)

Search for package or bug name: Reporting problems