CVE-2008-7129

NameCVE-2008-7129
DescriptionXySSL before 0.9 allows remote attackers to cause a denial of service (infinite loop) via an X.509 certificate that does not pass the RSA signature check during verification.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs543150

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
polarssl (PTS)jessie1.3.9-2.1+deb8u3fixed
jessie (security)1.3.9-2.1+deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdkimITP543150
polarsslsource(unstable)(not affected)
xysslsource(unstable)0.9-1medium

Notes

- polarssl <not-affected> (fixed in xyssl before polarssl was forked from it)
check pdkim if/when it enters unstable (contains polarssl code copy)

Search for package or bug name: Reporting problems