CVE-2008-7159

NameCVE-2008-7159
DescriptionThe silc_asn1_encoder function in lib/silcasn1/silcasn1_encode.c in Secure Internet Live Conferencing (SILC) Toolkit before 1.1.8 allows remote attackers to overwrite a stack location and possibly execute arbitrary code via a crafted OID value, related to incorrect use of a %lu format string.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1879-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
silc-client (PTS)squeeze1.1.7-2fixed
silc-server (PTS)squeeze1.1.18-1fixed
silc-toolkit (PTS)squeeze1.1.10-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
silc-clientsource(unstable)1.1-2low
silc-clientsourcelenny1.1.4-1+lenny1mediumDSA-1879-1
silc-serversource(unstable)(not affected)
silc-toolkitsource(unstable)1.1.10-1low
silc-toolkitsourcelenny1.1.7-2+lenny1medium

Notes

- silc-server <not-affected> (Vulnerable code not present)
silc-client uses libsilc from silc-toolkit since 1.1-2

Search for package or bug name: Reporting problems