DescriptionBIND 9.6.0, 9.5.1, 9.5.0, 9.4.3, and earlier does not properly check the return value from the OpenSSL DSA_verify function, which allows remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature, a similar vulnerability to CVE-2008-5077.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs511936

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)wheezy1:9.8.4.dfsg.P1-6+nmu2+deb7u10fixed
wheezy (security)1:9.8.4.dfsg.P1-6+nmu2+deb7u20fixed
jessie (security)1:9.9.5.dfsg-9+deb8u15fixed
stretch (security), stretch1:9.10.3.dfsg.P4-12.3+deb9u4fixed
buster, sid1:9.11.2.P1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


unlike the advisory states it is DSA_do_verify not DSA_verify
low severity because it is believed hard to trigger and only
affects DNSSEC with DSA, which is supposedly rarely used.

Search for package or bug name: Reporting problems