CVE-2009-0040

NameCVE-2009-0040
DescriptionThe PNG reference library (aka libpng) before 1.0.43, and 1.2.x before 1.2.35, as used in pngcrush and other applications, allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PNG file that triggers a free of an uninitialized pointer in (1) the png_read_png function, (2) pCAL chunk handling, or (3) setup of 16-bit gamma tables.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1750-1, DSA-1830-1
NVD severitymedium (attack range: remote)
Debian Bugs516256, 535124
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.8.0-1~deb7u1fixed
jessie31.7.0-1~deb8u1fixed
jessie (security)31.8.0-1~deb8u1fixed
stretch31.7.0-1fixed
sid38.1.0-1fixed
libpng (PTS)squeeze, squeeze (security)1.2.44-1+squeeze4fixed
wheezy1.2.49-1fixed
stretch, sid, jessie1.2.50-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)2.0.0.22-1medium535124
icedovesourcelenny2.0.0.22-0lenny1mediumDSA-1830-1
icedovesourcesqueeze2.0.0.22-0lenny1medium
libpngsource(unstable)1.2.35-1medium516256
libpngsourceetch1.2.15~beta5-1+etch2mediumDSA-1750-1
libpngsourcelenny1.2.27-2+lenny2mediumDSA-1750-1

Search for package or bug name: Reporting problems