CVE-2009-0050

NameCVE-2009-0050
DescriptionLasso 2.2.1 and earlier does not properly check the return value from the OpenSSL DSA_verify function, which allows remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature, a similar vulnerability to CVE-2008-5077.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1700-1
NVD severitymedium (attack range: remote)
Debian Bugs511262

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lasso (PTS)wheezy2.3.6-2fixed
jessie2.4.1-1fixed
buster, sid, stretch2.5.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lassosource(unstable)2.2.1-2medium511262
lassosourceetch0.6.5-3+etch1mediumDSA-1700-1

Search for package or bug name: Reporting problems