CVE-2009-0148

NameCVE-2009-0148
DescriptionMultiple buffer overflows in Cscope before 15.7a allow remote attackers to execute arbitrary code via long strings in input such as (1) source-code tokens and (2) pathnames, related to integer overflows in some cases. NOTE: this issue exists because of an incomplete fix for CVE-2004-2541.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1806-1
NVD severityhigh (attack range: remote)
Debian Bugs528510

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cscope (PTS)wheezy15.7a-3.6fixed
jessie15.8a-2fixed
stretch15.8b-2fixed
buster, sid15.8b-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cscopesource(unstable)15.7a-1low528510
cscopesourceetch15.6-2+etch1highDSA-1806-1
cscopesourcelenny15.6-6+lenny1highDSA-1806-1

Search for package or bug name: Reporting problems