CVE-2009-0186

NameCVE-2009-0186
DescriptionInteger overflow in libsndfile 1.0.18, as used in Winamp and other products, allows context-dependent attackers to execute arbitrary code via crafted description chunks in a CAF audio file, leading to a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1742-1, DTSA-202-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)squeeze (security), squeeze1.0.21-3+squeeze1fixed
wheezy1.0.25-5fixed
sid, jessie1.0.25-9.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesource(unstable)1.0.19-1medium
libsndfilesourceetch1.0.16-2+etch1highDSA-1742-1
libsndfilesourcelenny1.0.17-4+lenny1highDSA-1742-1
libsndfilesourcesqueeze1.0.18-2+squeeze1highDTSA-202-1

Search for package or bug name: Reporting problems