CVE-2009-0195

NameCVE-2009-0195
DescriptionHeap-based buffer overflow in Xpdf 3.02pl2 and earlier, CUPS 1.3.9, and probably other products, allows remote attackers to execute arbitrary code via a PDF file with crafted JBIG2 symbol dictionary segments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1790-1
Debian Bugs524809

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xpdf (PTS)bullseye3.04+git20210103-3fixed
bookworm3.04+git20220601-1fixed
trixie, sid3.04+git20240613-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xpdfsourceetch3.01-9.1+etch6DSA-1790-1
xpdfsourcelenny3.02-1.4+lenny1DSA-1790-1
xpdfsourcesqueeze3.02-1.4+lenny1
xpdfsource(unstable)3.02-1.4+lenny1medium524809

Search for package or bug name: Reporting problems