CVE-2009-0543

NameCVE-2009-0543
DescriptionProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1727-1, DSA-1730-1
Debian Bugs516388

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)buster1.3.6-4+deb10u6fixed
buster (security)1.3.6-4+deb10u4fixed
bullseye1.3.7a+dfsg-12+deb11u2fixed
bookworm1.3.8+dfsg-4+deb12u3fixed
trixie1.3.8.b+dfsg-1fixed
sid1.3.8.b+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpd-dfsgsourceetch(not affected)
proftpd-dfsgsourcelenny1.3.1-17lenny2
proftpd-dfsgsource(unstable)1.3.2-1medium516388

Notes

[etch] - proftpd-dfsg <not-affected> (etch version not affected)

Search for package or bug name: Reporting problems