CVE-2009-0579

NameCVE-2009-0579
DescriptionLinux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs514437

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pam (PTS)stretch1.1.8-3.6fixed
bullseye, buster, sid1.3.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pamsource(unstable)1.0.1-10unimportant514437

Notes

the ability to change a password earlier than scheduled is not a security
vulnerability in itself (unless the user changes their password back to
their previous password; thus violating the security policy as defined by
the administrator)

Search for package or bug name: Reporting problems