CVE-2009-0587

NameCVE-2009-0587
DescriptionMultiple integer overflows in Evolution Data Server (aka evolution-data-server) before 2.24.5 allow context-dependent attackers to execute arbitrary code via a long string that is converted to a base64 representation in (1) addressbook/libebook/e-vcard.c in evc or (2) camel/camel-mime-utils.c in libcamel.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1813-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
evolution-data-server (PTS)wheezy3.4.4-3+deb7u1fixed
jessie3.12.9~git20141128.5242b0-2+deb8u3fixed
stretch3.22.7-1fixed
buster3.26.2.1-1fixed
sid3.26.2.1-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
evolution-data-serversource(unstable)2.22.3-1medium
evolution-data-serversourceetch1.6.3-5etch2highDSA-1813-1
evolution-data-serversourcelenny2.22.3-1.1+lenny1highDSA-1813-1

Notes

this version doesnt fix the overflows but uses the glib functions for decoding instead

Search for package or bug name: Reporting problems