CVE-2009-0599

NameCVE-2009-0599
DescriptionBuffer overflow in wiretap/netscreen.c in Wireshark 0.99.7 through 1.0.5 allows user-assisted remote attackers to cause a denial of service (application crash) via a malformed NetScreen snoop file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)buster2.6.20-0+deb10u4fixed
buster (security)2.6.20-0+deb10u7fixed
bullseye (security), bullseye3.4.10-0+deb11u1fixed
bookworm, bookworm (security)4.0.6-1~deb12u1fixed
sid, trixie4.0.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourceetch(not affected)
wiresharksourcelenny1.0.2-3+lenny4
wiresharksource(unstable)1.0.6-1

Notes

[etch] - wireshark <not-affected> (Vulnerable code not present, introduced in 0.99.7)

Search for package or bug name: Reporting problems