CVE-2009-0733

NameCVE-2009-0733
DescriptionMultiple stack-based buffer overflows in the ReadSetOfCurves function in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file associated with a large integer value for the (1) input or (2) output channel, related to the ReadLUT_A2B and ReadLUT_B2A functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1745-1, DSA-1769-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs522446
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lcms (PTS)squeeze1.18.dfsg-1.2fixed
wheezy1.19.dfsg-1.2fixed
openjdk-6 (PTS)squeeze6b18-1.8.13-0+squeeze2fixed
squeeze (security)6b31-1.13.3-1~deb6u1fixed
squeeze (lts)6b34-1.13.6-1~deb6u1fixed
wheezy6b27-1.12.5-1fixed
wheezy (security)6b35-1.13.7-1~deb7u1fixed
sid6b35-1.13.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lcmssource(unstable)1.18.dfsg-1high522446
lcmssourceetch1.15-1.1+etch2highDSA-1745-1
lcmssourcelenny1.17.dfsg-1+lenny1highDSA-1745-1
openjdk-6source(unstable)6b18-1.8.13-0+squeeze2high
openjdk-6sourcelenny6b11-9.1+lenny2highDSA-1769-1

Notes

Marking the current oldstable version as fixed, but likely fixed way earlier

Search for package or bug name: Reporting problems