CVE-2009-0737

NameCVE-2009-0737
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1901-1
Debian Bugs514547

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2fixed
buster (security)1:1.31.16-1+deb10u7fixed
bullseye (security), bullseye1:1.35.13-1~deb11u1fixed
bookworm, bookworm (security)1:1.39.5-1~deb12u1fixed
sid, trixie1:1.39.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourceetch(not affected)
mediawikisourcelenny1:1.12.0-2lenny3
mediawikisource(unstable)1:1.14.0-1low514547
mediawiki1.7sourceetch1.7.1-9etch1DSA-1901-1
mediawiki1.7source(unstable)(unfixed)

Notes

[etch] - mediawiki <not-affected> (metapackage)

Search for package or bug name: Reporting problems