CVE-2009-0749

NameCVE-2009-0749
DescriptionUse-after-free vulnerability in the GIFReadNextExtension function in lib/pngxtern/gif/gifread.c in OptiPNG 0.6.2 and earlier allows context-dependent attackers to cause a denial of service (application crash) via a crafted GIF image that causes the realloc function to return a new pointer, which triggers memory corruption when the old pointer is accessed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optipng (PTS)jessie (security), jessie0.7.5-1+deb8u2fixed
stretch (security), stretch0.7.6-1+deb9u1fixed
buster, bullseye, sid0.7.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
optipngsource(unstable)0.6.2.1-1low
optipngsourceetch0.5.5-2high
optipngsourcelenny0.6.1.1-2high

Search for package or bug name: Reporting problems