CVE-2009-0751

NameCVE-2009-0751
DescriptionYaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1740-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
yaws (PTS)squeeze1.88-2+squeeze1fixed
wheezy1.94-1fixed
stretch, jessie, sid1.98-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
yawssource(unstable)1.80-1medium
yawssourceetch1.65-4etch1mediumDSA-1740-1
yawssourcelenny1.77-3+lenny1mediumDSA-1740-1

Search for package or bug name: Reporting problems