CVE-2009-0755

NameCVE-2009-0755
DescriptionThe FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1941-1
Debian Bugs518478

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)buster0.71.0-5fixed
buster (security)0.71.0-5+deb10u3fixed
bullseye (security), bullseye20.09.0-3.1+deb11u1fixed
bookworm22.12.0-2fixed
trixie, sid24.02.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourceetch(not affected)
popplersourcelenny0.8.7-3DSA-1941-1
popplersource(unstable)0.10.6-1low518478

Notes

[lenny] - poppler <no-dsa> (Application crash only, could be fixed with further issues)
[etch] - poppler <not-affected> (vulnerable code not present; forms introduced after 0.4.5)

Search for package or bug name: Reporting problems