CVE-2009-0783

NameCVE-2009-0783
DescriptionApache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 permits web applications to replace an XML parser used for other web applications, which allows local users to read or modify the (1) web.xml, (2) context.xml, or (3) tld files of arbitrary web applications via a crafted application that is loaded earlier than the target application.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2207-1
NVD severitymedium (attack range: local)
Debian Bugs532362, 532363, 532366
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)squeeze, squeeze (security)6.0.35-1+squeeze4fixed
squeeze (lts)6.0.41-2+squeeze6fixed
wheezy, wheezy (security)6.0.35-6+deb7u1fixed
jessie6.0.41-3fixed
stretch, sid6.0.41-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat5source(unstable)(unfixed)low532363
tomcat5.5source(unstable)(unfixed)low532366
tomcat5.5sourcelenny5.5.26-5lenny2mediumDSA-2207-1
tomcat6source(unstable)6.0.20-1low532362
tomcat6sourcelenny(not affected)

Notes

[lenny] - tomcat6 <not-affected> (Only ships the servlet package)

Search for package or bug name: Reporting problems