CVE-2009-0790

NameCVE-2009-0790
DescriptionThe pluto IKE daemon in Openswan and Strongswan IPsec 2.6 before 2.6.21 and 2.4 before 2.4.14, and Strongswan 4.2 before 4.2.14 and 2.8 before 2.8.9, allows remote attackers to cause a denial of service (daemon crash and restart) via a crafted (1) R_U_THERE or (2) R_U_THERE_ACK Dead Peer Detection (DPD) IPsec IKE Notification message that triggers a NULL pointer dereference related to inconsistent ISAKMP state and the lack of a phase2 state association in DPD.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1759-1, DSA-1760-1
NVD severitymedium (attack range: remote)
Debian Bugs521949, 521950
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openswan (PTS)squeeze (security)1:2.6.28+dfsg-5+squeeze2fixed
wheezy1:2.6.37-3fixed
wheezy (security)1:2.6.37-3+deb7u1fixed
strongswan (PTS)squeeze (security), squeeze4.4.1-5.6fixed
wheezy4.5.2-1.5+deb7u4fixed
wheezy (security)4.5.2-1.5+deb7u6fixed
jessie, sid5.2.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openswansource(unstable)1:2.6.21+dfsg-1medium521949
openswansourceetch1:2.4.6+dfsg.2-1.1+etch1mediumDSA-1760-1
openswansourcelenny1:2.4.12+dfsg-1.3+lenny1mediumDSA-1760-1
strongswansource(unstable)4.2.14-1medium521950
strongswansourceetch2.8.0+dfsg-1+etch1mediumDSA-1759-1
strongswansourcelenny4.2.4-5+lenny1mediumDSA-1759-1

Search for package or bug name: Reporting problems