CVE-2009-0835

NameCVE-2009-0835
DescriptionThe __secure_computing function in kernel/seccomp.c in the seccomp subsystem in the Linux kernel 2.6.28.7 and earlier on the x86_64 platform, when CONFIG_SECCOMP is enabled, does not properly handle (1) a 32-bit process making a 64-bit syscall or (2) a 64-bit process making a 32-bit syscall, which allows local users to bypass intended access restrictions via crafted syscalls that are misinterpreted as (a) stat or (b) chmod, a related issue to CVE-2009-0342 and CVE-2009-0343.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1800-1
NVD severitylow (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.30-1low
linux-2.6sourceetch(not affected)
linux-2.6sourcelenny2.6.26-15lenny2lowDSA-1800-1
linux-2.6.24source(unstable)(unfixed)low
user-mode-linuxsourcelenny2.6.26-1um-2+15lenny2lowDSA-1800-1

Notes

[etch] - linux-2.6 <not-affected> (Not enabled in 2.6.18)
[etch] - linux-2.6.24 <no-dsa> (unimportant)
CONFIG_SECCOMP has only been enabled in 2.6.26

Search for package or bug name: Reporting problems