CVE-2009-0841

NameCVE-2009-0841
DescriptionDirectory traversal vulnerability in mapserv.c in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2, when running on Windows with Cygwin, allows remote attackers to create arbitrary files via a .. (dot dot) in the id parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1914-1
NVD severityhigh (attack range: remote)
Debian Bugs523027

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)wheezy6.0.1-3.2+deb7u2fixed
wheezy (security)6.0.1-3.2+deb7u4fixed
jessie (security), jessie6.4.1-5+deb8u3fixed
stretch7.0.4-2fixed
buster, sid7.0.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)5.2.2-1high523027
mapserversourceetch4.10.0-5.1+etch4highDSA-1914-1
mapserversourcelenny5.0.3-3+lenny4highDSA-1914-1

Notes

this doesn't work under linux as the root from the directory traversal needs to exist

Search for package or bug name: Reporting problems