CVE-2009-0934

NameCVE-2009-0934
DescriptionCross-site scripting (XSS) vulnerability in ejabberd before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via unknown vectors related to links and MUC logs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1774-1
NVD severitymedium (attack range: remote)
Debian Bugs520852

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ejabberd (PTS)wheezy2.1.10-4+deb7u1fixed
wheezy (security)2.1.10-4+deb7u2fixed
jessie14.07-4+deb8u3fixed
stretch16.09-4fixed
buster, sid17.08-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ejabberdsource(unstable)2.0.5-1medium520852
ejabberdsourceetch(not affected)
ejabberdsourcelenny2.0.1-6+lenny1mediumDSA-1774-1

Notes

[etch] - ejabberd <not-affected> (Vulnerable expression not present)

Search for package or bug name: Reporting problems