CVE-2009-1046

NameCVE-2009-1046
DescriptionThe console selection feature in the Linux kernel 2.6.28 before 2.6.28.4, 2.6.25, and possibly earlier versions, when the UTF-8 console is used, allows physically proximate attackers to cause a denial of service (memory corruption) by selecting a small number of 3-byte UTF-8 characters, which triggers an "an off-by-two memory error." NOTE: it is not clear whether this issue crosses privilege boundaries.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1787-1, DSA-1800-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.29-1medium
linux-2.6sourceetch(not affected)
linux-2.6sourcelenny2.6.26-15lenny2mediumDSA-1800-1
linux-2.6.24source(unstable)(unfixed)medium
linux-2.6.24sourceetch2.6.24-6~etchnhalf.8etch1mediumDSA-1787-1
user-mode-linuxsourcelenny2.6.26-1um-2+15lenny2mediumDSA-1800-1

Notes

[etch] - linux-2.6 <not-affected> (Introduced in 2.6.23-rc1)

Search for package or bug name: Reporting problems