CVE-2009-1094

NameCVE-2009-1094
DescriptionUnspecified vulnerability in the LDAP implementation in Java SE Development Kit (JDK) and Java Runtime Environment (JRE) 5.0 Update 17 and earlier; 6 Update 12 and earlier; SDK and JRE 1.3.1_24 and earlier; and 1.4.2_19 and earlier allows remote LDAP servers to execute arbitrary code via unknown vectors related to serialized data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1769-1
NVD severityhigh (attack range: remote)
Debian Bugs521414

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-6sourcelenny6b11-9.1+lenny2highDSA-1769-1
sun-java5source(unstable)1.5.0-18-1high
sun-java5sourcelenny1.5.0-22-0lenny1high
sun-java6source(unstable)6-13-1high521414
sun-java6sourcelenny6-20-0lenny1high

Notes

[etch] - sun-java5 <no-dsa> (Non-free not supported)

Search for package or bug name: Reporting problems