CVE-2009-1098

NameCVE-2009-1098
DescriptionBuffer overflow in Java SE Development Kit (JDK) and Java Runtime Environment (JRE) 5.0 Update 17 and earlier; 6 Update 12 and earlier; 1.4.2_19 and earlier; and 1.3.1_24 and earlier allows remote attackers to access files or execute arbitrary code via a crafted GIF image, aka CR 6804998.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1769-1
NVD severityhigh (attack range: remote)
Debian Bugs521414

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-6sourcelenny6b11-9.1+lenny2highDSA-1769-1
sun-java6source(unstable)6-13-1high521414
sun-java6sourcelenny6-20-0lenny1high

Search for package or bug name: Reporting problems