CVE-2009-1176

NameCVE-2009-1176
Descriptionmapserv.c in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2 does not ensure that the string holding the id parameter ends in a '\0' character, which allows remote attackers to conduct buffer-overflow attacks or have unspecified other impact via a long id parameter in a query action.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1914-1
NVD severityhigh
Debian Bugs523027

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)stretch7.0.4-2fixed
buster7.2.2-1fixed
bullseye, sid7.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversourceetch4.10.0-5.1+etch4DSA-1914-1
mapserversourcelenny5.0.3-3+lenny4DSA-1914-1
mapserversource(unstable)5.2.2-1low523027

Notes

covered by 02_CVE-2009-840-CVE-2009-2281.dpatch as well

Search for package or bug name: Reporting problems