CVE-2009-1182

NameCVE-2009-1182
DescriptionMultiple buffer overflows in the JBIG2 MMR decoder in Xpdf 3.02pl2 and earlier, CUPS 1.3.9 and earlier, Poppler before 0.10.6, and other products allow remote attackers to execute arbitrary code via a crafted PDF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1790-1, DSA-1793-1
NVD severityhigh (attack range: remote)
Debian Bugs524806, 524809, 524810

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6fixed
wheezy (security)0.18.4-6+deb7u1fixed
jessie (security), jessie0.26.5-2+deb8u1fixed
stretch, sid0.48.0-2fixed
swftools (PTS)wheezy0.9.2+ds1-3fixed
jessie0.9.2+git20130725-2fixed
stretch, sid0.9.2+git20130725-4fixed
xpdf (PTS)wheezy3.03-10fixed
jessie3.03-17fixed
stretch, sid3.04-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)4:4.0-1medium524810
kdegraphicssourceetch4:3.5.5-3etch3highDSA-1793-1
kdegraphicssourcelenny4:3.5.9-3+lenny1highDSA-1793-1
popplersource(unstable)0.10.6-1medium524806
popplersourcelenny0.8.7-2high
swftoolssource(unstable)0.9.2+ds1-2high
xpdfsource(unstable)3.02-1.4+lenny1medium524809
xpdfsourceetch3.01-9.1+etch6highDSA-1790-1
xpdfsourcelenny3.02-1.4+lenny1highDSA-1790-1
xpdfsourcesqueeze3.02-1.4+lenny1high

Search for package or bug name: Reporting problems