CVE-2009-1183

NameCVE-2009-1183
DescriptionThe JBIG2 MMR decoder in Xpdf 3.02pl2 and earlier, CUPS 1.3.9 and earlier, Poppler before 0.10.6, and other products allows remote attackers to cause a denial of service (infinite loop and hang) via a crafted PDF file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1790-1, DSA-1793-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs524806, 524809, 524810
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kdegraphics (PTS)squeeze4:4.4.5-2fixed
poppler (PTS)squeeze (security), squeeze0.12.4-1.2+squeeze3fixed
squeeze (lts)0.12.4-1.2+squeeze4fixed
wheezy0.18.4-6fixed
jessie, sid0.26.5-2fixed
swftools (PTS)wheezy0.9.2+ds1-3fixed
jessie, sid0.9.2+git20130725-2fixed
xpdf (PTS)squeeze3.02-12+squeeze1fixed
wheezy3.03-10fixed
jessie, sid3.03-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)4:4.0medium524810
kdegraphicssourceetch4:3.5.5-3etch3mediumDSA-1793-1
kdegraphicssourcelenny4:3.5.9-3+lenny1mediumDSA-1793-1
popplersource(unstable)0.10.6-1medium524806
popplersourcelenny0.8.7-2medium
swftoolssource(unstable)0.9.2+ds1-2medium
xpdfsource(unstable)3.02-1.4+lenny1medium524809
xpdfsourceetch3.01-9.1+etch6mediumDSA-1790-1
xpdfsourcelenny3.02-1.4+lenny1mediumDSA-1790-1
xpdfsourcesqueeze3.02-1.4+lenny1medium

Search for package or bug name: Reporting problems