CVE-2009-1186

NameCVE-2009-1186
DescriptionBuffer overflow in the util_path_encode function in udev/lib/libudev-util.c in udev before 1.4.1 allows local users to cause a denial of service (service outage) via vectors that trigger a call with crafted arguments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1772-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
udev (PTS)wheezy175-7.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
udevsource(unstable)0.141-1medium
udevsourceetch0.105-4etch1lowDSA-1772-1
udevsourcelenny0.125-7+lenny1lowDSA-1772-1

Search for package or bug name: Reporting problems