CVE-2009-1187

NameCVE-2009-1187
DescriptionInteger overflow in the JBIG2 decoding feature in Poppler before 0.10.6 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to CairoOutputDev (CairoOutputDev.cc).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1941-1
NVD severitymedium
Debian Bugs524806

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)stretch0.48.0-2+deb9u2fixed
stretch (security)0.48.0-2+deb9u3fixed
buster0.71.0-5fixed
bullseye, sid20.09.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourcelenny0.8.7-3DSA-1941-1
popplersource(unstable)0.10.6-1medium524806

Search for package or bug name: Reporting problems