CVE-2009-1188

NameCVE-2009-1188
DescriptionInteger overflow in the JBIG2 decoding feature in the SplashBitmap::SplashBitmap function in SplashBitmap.cc in Xpdf 3.x before 3.02pl4 and Poppler before 0.10.6, as used in GPdf and kdegraphics KPDF, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2028-1, DSA-2050-1
NVD severitymedium (attack range: remote)
Debian Bugs524806, 575779

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6fixed
wheezy (security)0.18.4-6+deb7u3fixed
jessie (security), jessie0.26.5-2+deb8u1fixed
stretch0.48.0-2fixed
buster, sid0.57.0-2fixed
swftools (PTS)wheezy0.9.2+ds1-3fixed
wheezy (security)0.9.2+ds1-3+deb7u1fixed
jessie0.9.2+git20130725-2fixed
stretch, buster, sid0.9.2+git20130725-4.1fixed
xpdf (PTS)wheezy3.03-10fixed
jessie3.03-17fixed
stretch, buster, sid3.04-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)4:4.0medium
kdegraphicssourcelenny4:3.5.9-3+lenny3mediumDSA-2050-1
popplersource(unstable)0.10.6-1medium524806
popplersourceetch(not affected)
popplersourcelenny0.8.7-3.1medium
swftoolssource(unstable)0.9.2+ds1-2medium
xpdfsource(unstable)3.02-2medium575779
xpdfsourcelenny3.02-1.4+lenny2mediumDSA-2028-1

Notes

[etch] - poppler <not-affected> (SplashBitmap code not present)

Search for package or bug name: Reporting problems