CVE-2009-1194

NameCVE-2009-1194
DescriptionInteger overflow in the pango_glyph_string_set_size function in pango/glyphstring.c in Pango before 1.24 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long glyph string that triggers a heap-based buffer overflow, as demonstrated by a long document.location value in Firefox.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1798-1
NVD severitymedium (attack range: remote)
Debian Bugs527474

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pango1.0 (PTS)wheezy1.30.0-1fixed
jessie1.36.8-3fixed
stretch1.40.5-1fixed
buster, sid1.40.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pango1.0source(unstable)1.24.0-2medium527474
pango1.0sourceetch1.14.8-5+etch1mediumDSA-1798-1
pango1.0sourcelenny1.20.5-3+lenny1mediumDSA-1798-1

Search for package or bug name: Reporting problems