CVE-2009-1271

NameCVE-2009-1271
DescriptionThe JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote attackers to cause a denial of service (segmentation fault) via a malformed string to the json_decode API function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1775-1, DSA-1789-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.39-0+deb7u2fixed
jessie, sid5.6.7+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-json-extsource(unstable)(unfixed)medium
php-json-extsourceetch1.2.1-3.2+etch1mediumDSA-1775-1
php4source(unstable)(not affected)
php5source(unstable)5.2.9.dfsg.1-1medium
php5sourceetch5.2.0+dfsg-8+etch15mediumDSA-1789-1
php5sourcelenny5.2.6.dfsg.1-1+lenny3mediumDSA-1789-1

Notes

- php4 <not-affected> (the JSON extension was introduced in php5.2)

Search for package or bug name: Reporting problems