CVE-2009-1358

NameCVE-2009-1358
Descriptionapt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allow remote attackers to trick apt into installing malicious repositories.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1779-1, DTSA-199-1
NVD severityhigh (attack range: remote)
Debian Bugs433091

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apt (PTS)wheezy0.9.7.9+deb7u7fixed
wheezy (security)0.9.7.9+deb7u6fixed
jessie1.0.9.8.3fixed
stretch, sid1.3~rc2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aptsource(unstable)0.7.21high433091
aptsourceetch0.6.46.4-0.1+etch1highDSA-1779-1
aptsourcelenny0.7.20.2+lenny1highDSA-1779-1
aptsourcesqueeze0.7.20.2+squeeze1highDTSA-199-1

Search for package or bug name: Reporting problems