CVE-2009-1375

NameCVE-2009-1375
DescriptionThe PurpleCircBuffer implementation in Pidgin (formerly Gaim) before 2.5.6 does not properly maintain a certain buffer, which allows remote attackers to cause a denial of service (memory corruption and application crash) via vectors involving the (1) XMPP or (2) Sametime protocol.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1805-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)squeeze, squeeze (security)2.7.3-1+squeeze4fixed
wheezy (security), wheezy2.10.10-1~deb7u1fixed
stretch, sid, jessie2.10.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gaimsource(unstable)(unfixed)medium
gaimsourcelenny(not affected)
pidginsource(unstable)2.5.6-1medium
pidginsourcelenny2.4.3-4lenny2mediumDSA-1805-1

Notes

[lenny] - gaim <not-affected> (Only a transitional package)

Search for package or bug name: Reporting problems