CVE-2009-1391

NameCVE-2009-1391
DescriptionOff-by-one error in the inflate function in Zlib.xs in Compress::Raw::Zlib Perl module before 2.017, as used in AMaViS, SpamAssassin, and possibly other products, allows context-dependent attackers to cause a denial of service (hang or crash) via a crafted zlib compressed stream that triggers a heap-based buffer overflow, as exploited in the wild by Trojan.Downloader-71014 in June 2009.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs532736, 532738

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcompress-raw-zlib-perl (PTS)buster2.084-1fixed
bullseye2.101-1fixed
bookworm2.204-1fixed
sid, trixie2.212-1fixed
perl (PTS)buster5.28.1-6+deb10u1fixed
bullseye5.32.1-4+deb11u3fixed
bullseye (security)5.32.1-4+deb11u1fixed
bookworm5.36.0-7+deb12u1fixed
sid, trixie5.38.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcompress-raw-zlib-perlsourcelenny2.012-1lenny1
libcompress-raw-zlib-perlsource(unstable)2.015-2low532738
perlsourceetch(not affected)
perlsourcelenny5.10.0-19lenny1
perlsource(unstable)5.10.0-23low532736

Notes

[etch] - perl <not-affected> (Doesn't yet include Compress-Raw-Zlib)

Search for package or bug name: Reporting problems