Descriptionlib/pk-libgcrypt.c in libgnutls in GnuTLS before 2.6.6 does not properly handle invalid DSA signatures, which allows remote attackers to cause a denial of service (application crash) and possibly have unspecified other impact via a malformed DSA key that triggers a (1) free of an uninitialized pointer or (2) double free.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)wheezy, wheezy (security)2.12.20-8+deb7u5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls13sourceetch(not affected)
gnutls26sourceetch(not affected)
gnutls26sourcelenny(not affected)


[lenny] - gnutls26 <not-affected> (Vulnerable code not present)
[etch] - gnutls26 <not-affected> (Vulnerable code not present)
[etch] - gnutls13 <not-affected> (Vulnerable code not present, only affects 2.6.x)

Search for package or bug name: Reporting problems