CVE-2009-1416

NameCVE-2009-1416
Descriptionlib/gnutls_pk.c in libgnutls in GnuTLS 2.5.0 through 2.6.5 generates RSA keys stored in DSA structures, instead of the intended DSA keys, which might allow remote attackers to spoof signatures on certificates or have unspecified other impact by leveraging an invalid DSA key.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls13source(unstable)(unfixed)high
gnutls13sourceetch(not affected)
gnutls26source(unstable)2.6.6-1medium
gnutls26sourcelenny(not affected)

Notes

[lenny] - gnutls26 <not-affected> (Vulnerable code not present, only affects 2.6.x)
[etch] - gnutls13 <not-affected> (Vulnerable code not present, only affects 2.6.x)

Search for package or bug name: Reporting problems