CVE-2009-1440

NameCVE-2009-1440
DescriptionIncomplete blacklist vulnerability in DownloadListCtrl.cpp in amule 2.2.4 allows remote attackers to conduct argument injection attacks into a command for mplayer via a crafted filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1821-1
NVD severitymedium (attack range: remote)
Debian Bugs525078

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
amule (PTS)wheezy2.3.1-9fixed
stretch1:2.3.2-1fixed
sid1:2.3.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
amulesource(unstable)2.2.5-1.1low525078
amulesourceetch(not affected)
amulesourcelenny2.2.1-1+lenny2mediumDSA-1821-1

Notes

[etch] - amule <not-affected> (Doesn't support preview of complete files, which is the vulnerable part)

Search for package or bug name: Reporting problems